sexta-feira, 22 de março de 2013

Lançamento Cisco Packet Tracer 6

Cisco libera a versão 6.0 do Cisco Packet Tracer para download no site www.netacad.com. É preciso estar registrado como aluno ou como instrutor para baixar. Disponível para Windows e Linux

Cisco Packet Tracer


O Cisco Packet Tracer é um simulador de redes que suporta dispositivos Cisco, diferente do GNS3 o Packet Tracer, após sua instalação, não precisa de nenhuma configuração adicional para ser utilizado.

A nova versão veio recheada de recursos novos e correção de bugs, porém acredito que novos bugs tenham vindo junto!

Novos dispositivos


Agora é possível adicionar a sua topologia os seguintes dispositivos:

  • Roteadores 1901, 1941,  2901, 2911


Complementos



  • Roteadores ganharam interface sem fio

  • HSRP

  • Servidores com recursos de Firewalls (IPv4 e IPv6) e agora é possível adicionar mais de uma interface ao mesmo

  • Cabo Octal

  • Módulo HWIC-A8

  • Tunelamento IPv6/IPv4

  • É possível filtrar o que pode ser acessado pelas opções; ex: Não permitir abrir a tab de interface, o multiuser menu, etc.

  • Adicionar interfaces customizadas (download site da cisco)

  • Adicionar scripts, módulos, pka, pkt, pkz customizados licenciados e não licenciados pela Cisco Networking Academy

  • O Menu de desenho ganhou um recurso para desenhar polígonos e alterar o tamanho de um desenho feito.

  • E outras coisas que eu posso ter deixado de lado e que ainda vou descobrir (ou não)!


Bugs Corrigidos


Tenho certeza que muitos bugs foram corrigidos, os que eu pude testar são:

Fim


Mesmo com todas as limitações e problemas o Packet Tracer é um ótimo programa para brincar / testar / estudar devido ao seu baixo consumo de memória , baixo consumo processamento e possibilidade de usar o simulation e ver o que há dentro de cada pacote (dependendo do filtro usado)

Amostra do Packet Tracer


Nova Versão do Packet Tracer é lançada

Referências


Clique nos links abaixo para ler mais sobre o packet tracer

segunda-feira, 18 de março de 2013

Comandos Básicos de Linux

Lista dos comandos básicos normalmente utilizados em sistemas operacionais linux. Sempre bom tê-la à mão

PORËM, saiba que é quase sempre possível filtrar a saída do comando usando "COMANDO + | grep XXXX"

onde XXX é o que se deseja filtrar, por exemplo:
ps aux | grep firefox

Comandos básicos Linux:



  • pwd -> Informa o diretório em que você está

  • dir +caminho+ -> acessa a pasta/caminho, ex: dir /etc/

  • ls -> Exibe os arquivos das pastas, para mais detalhes, ls -al

  • cat +file+ -> exibe o conteudo completo do arquivo, em formato texto, exemplo: cat /etc/hosts.conf

  • tail +file+ -> exibe o final do arquivo, em formato texto, exemplo: tail /etc/hosts.conf

  • mkdir +nome+ -> cria um diretório

  • rm +arquivo+ -> apaga um arquivo

  • rmdir +nomePasta+ -> apaga uma pasta

  • cp +origem+ +destino+ -> move um arquivo de uma origem para um destino

  • mv +origem+ +destino+ -> move um arquivo de uma origem para um destino

  • kill +PUID+ -> Encerra o software que corresponde ao PUID

  • shutdown -h 0 -> desliga o sistema operacional


Comandos de verificação:



  • df -> exibe a utilização do espaço em disco, dica: use df -h

  • free -m -> exibe a memória ram livre e usada

  • lspci -> exibe informações sobre barramento PCI conectados ao seu pc

  • ifconfig -a -> informações sobre todas as placas de rede

  • ifconfig eth0 -> informações sobre a NIC eth0

  • netstat -rn -> exibe a tabela de roteamento

  • netstat -pn -> exibe em quais portas o pc está escutando

  • nslookup -> resolve um nome em IP

  • ps aux -> exibe os procesos em execução (com PUID)

  • top -> gerenciador de tarefas em tempo real

  • uname -a -> exibe informações sobre a arquitetura e sistema operacional

  • smbstatus -> lista o status do samba


Comandos de Configuração



  • ifconfig eth0 192.168.0.10 netmask 255.255.255.0 -> configura ip em uma interface

  • ifconfig eth0 up -> Ativa a interface

  • route add default gw 192.168.0.1 eth0 -> Adiciona um gateway padrão

  • route add network 10.0.0.0/18 gw 192.168.0.2 eth0 -> adiciona uma rota estática para uma rede

  • route del network 10.0.0.0/18 gw 192.168.0.2 -> remove uma rota estática de rede


Muitas configurações do linux são feitas editando arquivos, portanto, use o vi, nano, gedit para alterar esses arquivos!

Comandos de Modificação/Gerenciamento



  • passwd +username+ ->Altera a senha do usuário

  • chmod <options> +pasta/arquivo+ -> Altera as permissões, ex: chmod -R 777 /home/pub/

  • chowner <options> +pasta/arquivo+ -> altera o dono da pasta / grupo. Exemplo chowner -R root:grupoADM /home/root/


Auto ajuda


Embora existam mais comandos e mais opções é possivel usar o comando:
man <command>

man faz referência a manual, ele exibe um manual de como usar o command escolhido

Referências


sexta-feira, 15 de março de 2013

Konami code na Internet

Certamente você se lembra do código mais famoso da Konami ↑ ↑ ↓ ↓ ← → ← → B A (Konami Code). Esse código continua existindo em muitos sites.

Sobre o código Konami


↑ ↑ ↓ ↓ ← → ← → B A (Konami Code) sem dúvidas foi marcante na infância e adolescência de muitas pessoas e devido a essa fama foi criado um tipo de easter egg (ovo de páscoa) abusarem desse código.

Digitando o Konami Code em alguns é possível encontrar áreas secretas configuradas pelo programador.

Sites que possuem o Konami Code


Clique em algum lugar do site, que não seja um link, e pressione a seguinte sequência de teclas:

↑ ↑ ↓ ↓ ← → ← → B A Enter

ps. alguns sites necessitam que você aperte Enter várias vezes.

Sites que aceitam o Konami Code



Colocar o Konami Code no seu site


Adicione a seguinte entrada entre as tags <head></head> do seu site:
<script type="text/javascript" src="https://raw.github.com/snaptortoise/konami-js/master/konami.js"></script>
<script type="text/javascript">
var konami = new Konami('http://www.google.com');
</script>

Mude o http://www.google.com para a ação desejada.

Referências



  • http://en.wikipedia.org/wiki/Konami_Code

  • http://pt.wikipedia.org/wiki/C%C3%B3digo_Konami


 

quarta-feira, 13 de março de 2013

Editor de Imagens GIMP GNU

Gratuito e Completo


GNU Image Manipulation Program (Programa de Manipulação de Imagem GNU) é um programa distribuído gratuitamente para Linux, Windows e MAC realizando tarefas como retoque em fotos, composição e edição de imagens.

GIMP é um editor de imagens gratuito e profissional. Com ele é possível criar artes com um nível de qualidade equivalentes a programas pagos além de ser escrito e desenhado para até as mais complicadas edições sejam feitas de maneira simples usando uma interface fácil e amigável.

Fácil de Mexer


É um programa de edição de fotos, no começo qualquer usuário precisa se esforçar um pouco para entender os atalhos e achar a posição das ferramentas mas após algum tempo o GIMP se torna seu programa de edição de fotos favorito!

Vídeo Dica


[caption id="attachment_214" align="alignleft" width="150"]RagazziD Imagem Gimp Imagem usada como exemplo no vídeo GIMP RagazziD[/caption]

Gravei um vídeo tutorial para demonstrar sua facilidade de edição e compatibilidade com diversos sistemas operacionais, vale a pena assistir (em 720p)
Segue o link para o vídeo:

http://www.youtube.com/watch?v=cT0o3Tk_2q4

O que o GIMP oferece?


Traduzido do site oficial

Desenho & Pintura

  • Conjunto completo de ferramentas de pintura, incluindo Brush, Pencil, Airbrush, Clone, etc

  • Sub-pixel de amostra para todas as ferramentas de pintura para alta qualidade anti-aliasing

  • Editor de gradiente extremamente poderoso e ferramentas de mistura

  • Suporta pincéis personalizados e padrões


Sistema

  • O gerenciamento de memória para o tamanho da imagem é limitado pelo hardware

  • Número virtualmente ilimitado de imagens abertas ao mesmo tempo (limitado pelo hardware)


Manipulação avançada

  • Apoio total do canal alfa (transparência)

  • Camadas e canais

  • Múltiplos desfazer / refazer (limitadas apenas pelo espaço em disco)

  • Camadas de texto editável

  • Ferramentas de transformação, incluindo rotação, escala, cisalhamento e flip

  • Ferramentas de seleção, incluindo retângulo, retângulo arredondado, elipse, livre, fuzzy

  • Ferramenta de extração de primeiro plano

  • Ferramenta avançada de seleção utilizando bezier e poligonos

  • Sequências e seleções transformáveis??.

  • QuickMask para pintar uma seleção.


Extensível

  • Banco de dados processuais para chamar funções do internas GIMP de programas externos como em Script-fu

  • Recursos avançados de scripts (Scheme, Python, Perl)

  • Plug-ins que permitem a fácil adição de novos formatos de arquivo e filtros com novos efeitos

  • Mais de 100 plug-ins já estão disponível


Animação

  • Carregar e salvar animações em um formato de quadro-a-camada conveniente

  • Suporta MNG

  • Quadro Navigator (em GAP, o pacote de animação do GIMP)

  • Onion Skin (em GAP, o pacote de animação do GIMP)

  • Bluebox (em GAP, o pacote de animação do GIMP)


Manipulação de arquivos

  • Os formatos de arquivos suportados incluem bmp, gif, jpeg, MNG, PCX, PDF, PNG, PS, PSD, SVG, TIFF, TGA, XPM, e muitos outros

  • Carregar, exibir, converter, salvar em diversos formatos de arquivos

  • Importação caminho SVG / exportação


E muito, muito, mais!

Onde Baixar o GIMP


É possível fazer o download do GIMP (para qualquer um dos sistemas operacionais suportados) na página do software: www.gimp.com.br

Referências


Acesse os links abaixo para:

terça-feira, 12 de março de 2013

Simulador de Rede GNS3

GNS3 (graphical network simulator - Simulador de Rede Gráfico) permite a simulação de redes complexas (e pode ser BEEEM complexa).

Sobre o GNS3


O GNS3 é um software para simulação de redes com dispositivos Cisco, Juniper, Linux, entre eles estão:

  • Cisco Roteadores (1700, 2600, 2691, 3600, 3700 e 7200)

  • Cisco PIX

  • Cisco ASA

  • Juniper Routers (dá um trabalho fazer funcionar, mas funciona)

  • IDS


Também existem dispositivos que já estão pré configurados, não é possível fazer muita coisa além do mínimo mas eles funcionam corretamente:

  • Switch Ethernet

  • Switch Frame Relay

  • ATM Switch

  • EtherSwitch Router


Também é possível adicionar hosts a sua rede para que a sua simulação fique ainda mais real e é possível fazer a rede do GNS3 se comunicar com a sua rede local ou com qualquer outra rede (que esteja conectada a sua placa de rede).

Requerimentos do Sistema


Pode-se instalar o GNS3 em qualquer um dos seguintes sistemas operacionais:

  • Windows (versões posteriores a XP, inclusive Windows 8)

  • Linux

  • Mac OS


Por ser tão completo os requerimentos do sistema são bem altos. O GNS3 irá dedicar parte da memória ram para cada dispositivo rodando e também irá fazer o processador trabalhar mais. Se iniciar 3 ASA 5525 mais 3 roteadores e 2 hosts o mínimo de Ram utilizada será por volta de 2 ou 3 GB (isso mesmo GB), porém se for apenas roteadores, 1700 ou 2600, isso irá cair para menos de 1 gb.

Como o GNS é um simulador é necessário ter o IOS (sistema operacional) do roteador / hosts (imagem linux por exemplo) para que ele funcione corretamente.
(veja o link da área de estudos explicando como fazer isso)

Integração com VmWare e VirtualBox


É possível fazer com que o GNS3 reconheça as máquinas virtuais do Virtual Box e as use dentro das redes, no caso do VmWare basta adicionar a interface vmware na nuvem (olhar tutorial no final do post)

Exemplo de uso: Instalei uma vez o Cisco ACS e um Windows Server em uma máquina virtual no VmWare e fiz a com que a rede do GNS3 os encontrassem, assim pude fazer com que os dispositivos de rede pudessem ser acessados (ssh e telnet) usando contas do AD do Windows Server usando Tacacs+.

Dessa maneira as aulas que leciono ficam mais interessantes do que simples imagens de power point

Referências



Para instalar é só dar N N F (next, next finish), bem fácil

[caption id="" align="alignnone" width="599"]RagazziD GNS3 FrameRelay GNS3 Rodando Frame Relay[/caption]

domingo, 10 de março de 2013

Por que colocar senha na rede Wireless?

Vale a pena colocar senha na rede wireless (sem fio)? Já se perguntou por que o gerenciador de rede dos sistemas operacionais (SO) dizem "Rede não segura" quando a mesma não possui senha?

Nota: wireless e sem fio são a mesma coisa, wireless = inglês e sem fio = português.

Como funciona uma rede sem fio - wireless?


A rede sem fio funciona como uma espécie de gritaria, quando um computador quer falar com outro ou com a internet o mesmo envia (basicamente) as seguintes informações.Alcance sem fio (wireless)  - RagazziD

  • Informações dele mesmo (origem)

  • Informações de quem ele quer trocar informações (destino)

  • Informações para o roteador sem fio interpretar isso

  • Payload -> Parte que fica as infomações como user e senha, busca do google, etc


 

Essas informações são propagadas para todo mundo, dentro do alcance do roteador, pois não se tem um local fixo para cada computador e é ai que mora o nosso problema.

Caso queria entender profundamente como isso funciona: Pesquise por CSMA/CA (Protocolo camada 2 para redes wireless)

O risco da rede sem senha


Toda informação que passam por sinais sem fio pode ser analisada usando certos métodos, isso quer dizer que é possível capturar algumas, ou todas, as informações e assim ver o seu chat, alguma senha, emails sendo enviados, no caso de smtp, ou emails sendo recebidos, no caso de pop.

A senha da rede wireless não impede apenas que pessoas acessem sua internet, quando se coloca a senha na wireless todo sinal, toda informação trocada, será criptografada, ou seja o tráfego será seguro. Criptografada?! Uma palavra difícil certo? Dizem que fotos valem mais do que mil palavras, portanto.. vamos testar:

[caption id="attachment_184" align="alignleft" width="210"]Captura sem senha wireless Sem senha todo o tráfego wireless consegue ser lido por qualquer um que esteja ouvindo o meio em texto claro, como FTP, HTTP, SMTP, etc.[/caption]

[caption id="attachment_183" align="alignright" width="210"]Tráfego Wireless Cryptografado Com senha todo o tráfego wireless não consegue ser lido por qualquer um pois agora as informações estão sendo criptografadas[/caption]

 

 

 

 

 

 

Se sentindo menos seguro? Calma, nem todo mundo sabe fazer isso! Porém é de extrema importância que você se proteja! Existem outras ameaças a rede sem fio.. mas esse é o primeiro passo.

Caso ainda não tenha lido, Mark Zuckerberg (fundador do Facbook)  teve seu Facebook invadido, mas como? Zuckerberg acredita que isso tenha acontecido enquanto o mesmo usava a rede sem fio pelo celular de algum cyber café. Portando, está ai uma prova que existem meios de capturar senhas usando redes sem fio!

Dicas para segurança wireless


Utilize, pelo menos, criptografia de WPA para cima.

Dicas para consultas



Fique ligado no blog, dicas de segurança virão! (não queria fazer o post ficar muito grande, por isso encerro aqui)

 

Bom começo de semana a todos!

sexta-feira, 8 de março de 2013

Slax, o Linux de bolso!

Precisa de um linux para levar no pendrive? Conheça o Slax, sistema operacional linux pequeno, rápido e completo

O sistema operacional Slax


O Slax é um moderno, portátil, pequeno e rápido sistema operacional com uma aproximação modular e design incrível. Apesar de seu pequeno tamanho, o Slax fornece uma grande coleção de softwares pré-instalados para o uso diário contando com uma organizada interface gráfica e úteis ferramentas de recuperação para administradores de sistemas

A aproximação modular dá a você a habilidade de incluir qualquer outro programa no Slax facilmente. Se você está sentindo falta do seu editor de texto favorito, da sua ferramente de rede ou de algum jogo, simplesmente faça o download do módulo do software (ou jogo), copie para o Slax digite um comando e pronto! Não há necessidades de instalar ou configurar. Simples, rápido, fácil e pequeno!

Baixei o Slax, o que eu posso fazer?


Após baixar o Slax, ele está disponível para download em português BR, é necessário gravar ele em um pendrive, hd externo, cd-rom e então começar a utilizado. É realmente incrível como 220mb de sistema operacional chega a ser tão completo. Segue a lista de alguns dos programas instalados:

  • Codecs para: MP3, MP4, MKV, WMA, WMV e outros

  • Rede: Sofware para gerenciamento de redes sem fio e com fio

  • GCC (Compilador de C, C++)

  • Firefox

  • Editor de Texto (gráfico, mas tem o vi também)

  • Pidgin (Instant Messenger)

  • Calculadora Científica

  • Visualizador de PDF e de Imagens

  • Jogos (Paciência e vários outros)

  • E muitos outros programas gráficos, além é claro dos comandos linux nativos, cat, put, echo, tail, vi, vim, tcpdump e muitos outros comandos CLI


Tudo isso em menos de 250 MB e o melhor, de graça!

Onde baixar o Slax?


Baixe o Slax direto do site: http://www.slax.org e faça um teste!

Como rodar o Slax?


No próprio site http://www.slax.org é possível encontrar informações sobre como rodar o Slax, mas aqui vão algumas dicas para a versão .ISO para CD

  1. Faça o download do Slax

  2. Grave ele em um CD

  3. Reinicie o computador com o CD gravado e faça que o computador boot pelo CDROM

  4. Aproveite o Slax


Dica para a versão para Pendrive

  1. Faça o download do Slax

  2. Copie o conteúdo do ZIP para a pasta raiz do pendrive (a pasta Slax)

  3. Acesse a pasta slax/boot/

  4. Execute o bootinst.bat

  5. Reinicie o computador com o Pendrive conectado e faça que o computador boot pelo pendrive

  6. Aproveite o Slax


Um ótimo final de semana a todos!

[caption id="" align="alignnone" width="700"]Slax - Area de Trabalho Slax Desktop - Área de Trabalho do Slax[/caption]

quinta-feira, 7 de março de 2013

Minha internet não funciona

Nem sempre quando a internet dá problemas quer dizer que é um defeito no roteador, no seu provedor de serviço ou de qualquer outra coisa.

"Minha internet não funciona" é uma clássica afirmação da maioria das pessoas quando não conseguem acessar algum site ou quando o jogo online trava, tem até aquele velho ditado:
Games doesn't make people violence, lag does!
---
Jogos não deixam as pessoas violentas, internet lenta deixa!

Eu pessoalmente prefiro que minha internet não funcione do que funcionar quando ela quer! Porém segue algumas dicas para que você mesmo consiga consertar a sua internet apenas verificando se está tudo ok com o seu computador.

Internet lenta


Caso a internet esteja lenta, verifique se não há mais nada utilizando o seu link de internet como:

  • Torrent

  • Downloads

  • Acesso a internet compartilhado

  • Streaming de video


Não consigo acessar a internet


Dizer que não é possível acessar a internet é algo muito genérico, aqui vão algumas dicas para verificar se o problema é no seu link de internet ou no seu computador:

1. Verifique se há um ip válido configurado:
1.1 Windows:
#Acesse o CMD (command line prompt do windows) e digite o seguinte comando
c:\>ipconfig

Windows IP Configuration

Ethernet adapter Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::49c4:cae8:b582:f2bc%35
Autoconfiguration IPv4 Address. . : 192.168.0.10
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1

1.2 Linux / MAC

Linux / MAC:
#Acesse o terminal e digite os seguintes comandos (pode -se precisar de privilégios de root)
root@study:~# ifconfig | grep inet
inet addr:192.168.0.10 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::a00:27ff:fe7c:a675/64 Scope:Link
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
#################################################
LINUX:
root@study:~#netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.0.0 0.0.0.0 255.255.252.0 U 0 0 0 eth0
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
##################################################
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
MAC:
pc1-Mac:~ ragazzid$ netstat -rn | grep default
default 192.168.0.1 UGSc 3 9 en0
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

Sem medo, se tiver algo diferente de vazio ou de 169.254.x.x pode-se dizer que a configuração para a internet está funcionando! Se não estiver tente verificar os cabos, verfique se está tudo ligado na tomada e funcionando corretamente

2. Agora é necessário verificar se o gateway configurado (quem te leva para a internet, ou seja o roteador) está ativo, para ver se ele está ativo digite:

2.1 Windows
c:\>ping 192.168.0.1

Pinging 192.168.0.1 with 32 bytes of data:
Reply from 192.168.0.1: bytes=32 time=2ms TTL=128
Reply from 192.168.0.1: bytes=32 time=

2.2 Linux / MAC
#Para parar o ping é necessário usar, no linux, control + c ou , no mac, command + c
root@study:~# ping 192.168.0.1
PING 135.75.120.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_req=1 ttl=255 time=0.715 ms
64 bytes from 192.168.0.1: icmp_req=2 ttl=255 time=0.795 ms
64 bytes from 192.168.0.1: icmp_req=3 ttl=255 time=0.780 ms
64 bytes from 192.168.0.1: icmp_req=4 ttl=255 time=0.730 ms
^C
--- 192.168.0.1 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2998ms
rtt min/avg/max/mdev = 0.715/0.755/0.795/0.033 ms
root@study:~#

Se nenhum time aparecer significa que sua conexão com o seu gateway está OK. No caso de timeouts verifique se o roteador está com todas as luzes piscando e se não há nenhum problema com os cabos.

3. Agora vamos testar se é possível acessar a internet
3.1 Windows
c:\>ping 4.2.2.2

Pinging 4.2.2.2 with 32 bytes of data:
Reply from 4.2.2.2: bytes=32 time=164ms TTL=51
Reply from 4.2.2.2: bytes=32 time=160ms TTL=51
Reply from 4.2.2.2: bytes=32 time=165ms TTL=51
Reply from 4.2.2.2: bytes=32 time=161ms TTL=51

Ping statistics for 4.2.2.2:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 160ms, Maximum = 165ms, Average = 162ms

3.2 Linux / MAC
#Para parar o ping é necessário usar, no linux, control + c ou , no mac, command + c
root@study:~# ping 4.2.2.2
PING 4.2.2.2 (4.2.2.2) 56(84) bytes of data.
64 bytes from 4.2.2.2: icmp_req=1 ttl=255 time=130ms
64 bytes from 4.2.2.2: icmp_req=2 ttl=255 time=190ms
64 bytes from 4.2.2.2: icmp_req=3 ttl=255 time=189ms
64 bytes from 4.2.2.2: icmp_req=4 ttl=255 time=140ms

Se não nenhum timeout for recebido, pode-se dizer que a conexão com a internet existe e o problema é algo relacionado a firewall, DNS ou é algum problema com o site. No caso de apresentar problemas pode-se dizer que o seu roteador não consegue ir para a internet em acessar a internet

4. Tudo deu certo mas não consigo acessar meu site, nesse caso é bom considerar:

  • Trocar o servidor DNS para 4.2.2.2 (free DNS), 8.8.8.8 (Free DNS Google)

  • Verificar a existência de firewalls ou proxy na rede

  • Ter certeza de que o site está funcionado

  • Etc!


Referências

Se quiser se aprofundar nesses assuntos recomendo os seguintes links:

 

quarta-feira, 6 de março de 2013

Pergunta de VPN - CCNA Security

VPN significa Virutal Private Network, é o túnel seguro formado entre pelo menos 2 pontos afim de criptografar toda a informação trocada a um nível extremamente seguro. Hoje em dia ela é usada para conectar redes distantes de maneira segura, por exemplo:

  • Quando um usuário doméstico trabalha de casa ele precisará, de algum jeito, acessar as informações da empresa. Normalmente isso é feito usando uma conexão vpn entre o computador e a empresa (algum servidor de VPN, podendo ser um roteador, um firewall ou um servidor windows ou linux)

  • Para proteger as informações que serão trocadas dentro de 2 pontos diferentes da mesma rede (dados bancários ou de finanças)


Há alguns dias recebi um e-mail de um ex-aluno de CCNA, agora instrutor de CCNA, me perguntando sobre por que sua topologia de VPN não estava funcionando, assunto de CCNA Security. Depois de enrolar um pouco consegui tempo para ver o problema e gostaria de compartilhar a resolução aqui:

Cenário


O software utilizado foi o Cisco Packet Tracer Version: 5.2.2.0019, veja a topologia abaixo:

[caption id="attachment_124" align="alignleft" width="300"]Topologia Topologia[/caption]

  •  A conexão de VPN está sendo feita entre R1 e R2

  • Não precisamos nos preocupar com a internet, pois a VPN passa transparente por ela

  • Temos que fazer que a rede 192.168.1.0/24 converse com a rede 192.168.2.0/24 pelo Túnel


Configurações dos dispositivos


A seguir as configurações dos dispositivos

R1:
Interface conectada com a rede interna  -> FastEthernet 0/0 192.168.1.1 /24
Interface conectada com a rede externa -> Serial 0/0 172.30.1.2/24
Configurações de VPN de R1:
crypto isakmp policy 10
encr 3des
hash md5
authentication pre-share
!
crypto isakmp key cisco123 address 172.30.2.2
!
crypto ipsec transform-set TS01 esp-3des esp-md5-hmac
!
crypto map MYMAP 10 ipsec-isakmp
set peer 172.30.2.2
set pfs group1
set security-association lifetime seconds 86400
set transform-set TS01
match address 110
!
access-list 102 permit ahp host 172.30.2.2 host 172.30.1.2
access-list 102 permit esp host 172.30.2.2 host 172.30.1.2
access-list 102 permit udp host 172.30.2.2 host 172.30.1.2 eq isakmp
access-list 102 permit ospf any any
!
access-list 110 permit tcp 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
access-list 110 permit icmp 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
!
interface Serial0/0/0
 ip address 172.30.1.2 255.255.255.0
 clock rate 2000000
ip access-group 102 in
 crypto map MYMAP

Tabela de roteamento de R1
     172.30.0.0/24 is subnetted, 2 subnets
C 172.30.1.0 is directly connected, Serial0/0/0
O 172.30.2.0 [110/128] via 172.30.1.1, 00:35:48, Serial0/0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
O 192.168.2.0/24 [110/129] via 172.30.1.1, 00:35:38, Serial0/0/0

R2:
Interface conectada com a rede interna -> FastEthernet 0/0 192.168.2.1 /24
Interface conectada com a rede externa -> Serial 0/0 172.30.2.2 /24
Configurações de VPN de R2:
crypto isakmp policy 10
encr 3des
hash md5
authentication pre-share
!
crypto isakmp key cisco123 address 172.30.1.2
!
!
crypto ipsec transform-set TS01 esp-3des esp-md5-hmac
!
crypto map MYMAP 10 ipsec-isakmp
set peer 172.30.1.2
set pfs group1
set security-association lifetime seconds 86400
set transform-set TS01
match address 110
!
access-list 102 permit ahp host 172.30.2.2 host 172.30.1.2
access-list 102 permit esp host 172.30.2.2 host 172.30.1.2
access-list 102 permit udp host 172.30.2.2 host 172.30.1.2 eq isakmp
access-list 102 permit ospf any any
!
access-list 110 permit tcp 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 110 permit icmp 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255
!
interface Serial0/0/0
ip address 172.30.2.2 255.255.255.0
ip access-group 102 in
crypto map MYMAP

Tabela de roteamento de R2:
     172.30.0.0/24 is subnetted, 2 subnets
O 172.30.1.0 [110/128] via 172.30.2.1, 00:34:27, Serial0/0/0
C 172.30.2.0 is directly connected, Serial0/0/0
O 192.168.1.0/24 [110/129] via 172.30.2.1, 00:34:27, Serial0/0/0
C 192.168.2.0/24 is directly connected, FastEthernet0/0

Sobre o cenário e VPN


Como podemos ver a comunicação está sendo feito por dentro de uma intranet, não há túnel para esconder as rotas, há apenas a necessidade de criptografar o tráfego entre a rede 192.168.1.0/24 e 192.168.2.0/24

Com essas configurações setadas, veja o que acontece quando uma configuração é iniciada (o teste foi, tentar pingar da rede 192.168.1.0 um host na 192.168.2.0):

Fase 1:
R1#show crypto isakmp sa
IPv4 Crypto ISAKMP SA
dst src state conn-id slot status
172.30.2.2 172.30.1.2 QM_IDLE 1003 0 ACTIVE
!
R2#show crypto isakmp sa
IPv4 Crypto ISAKMP SA
dst src state conn-id slot status
172.30.1.2 172.30.2.2 QM_IDLE 1032 0 ACTIVE

Como podemos ver, tudo está certinho na fase 1, agora vamos ver a fase 2

Fase 2:
R1#show crypto ipsec sa

interface: Serial0/0/0
Crypto map tag: MYMAP, local addr 172.30.1.2

protected vrf: (none)
local ident (addr/mask/prot/port): (192.168.1.0/255.255.255.0/6/0)
remote ident (addr/mask/prot/port): (192.168.2.0/255.255.255.0/6/0)
current_peer 172.30.2.2 port 500
PERMIT, flags={origin_is_acl,}
#pkts encaps: 3, #pkts encrypt: 3, #pkts digest: 0
#pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0
#pkts compressed: 0, #pkts decompressed: 0
#pkts not compressed: 0, #pkts compr. failed: 0
#pkts not decompressed: 0, #pkts decompress failed: 0
#send errors 1, #recv errors 0

local crypto endpt.: 172.30.1.2, remote crypto endpt.:172.30.2.2
path mtu 1500, ip mtu 1500, ip mtu idb Serial0/0/0
current outbound spi: 0x615C2599(1633428889)

Aqui encontramos um problema, conseguimos ver pacotes sendo encapsulados e criptografados porém não conseguimos ver nenhum pacote descriptografado:
   #pkts encaps: 3, #pkts encrypt: 3, #pkts digest: 0
#pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0

Isso pode acontecer devido a muitos problemas, primeiro vamos ver se as ACL's estão sendo correspondidas:
R1#sh access-lists 
Extended IP access list 102
    permit ahp host 172.30.2.2 host 172.30.1.2
    permit esp host 172.30.2.2 host 172.30.1.2
    permit udp host 172.30.2.2 host 172.30.1.2 eq isakmp
!

R1#sh access-lists
Extended IP access list 102
    permit ahp host 172.30.2.2 host 172.30.1.2
    permit esp host 172.30.2.2 host 172.30.1.2
    permit udp host 172.30.2.2 host 172.30.1.2 eq isakmp

Problema localizado, como o tráfego está sendo criptografado mas não mostra que nenhuma acl foi usada?

Esse é um bug do packet tracer! O mesmo cenário foi testado no GNS3 e funcionou normalmente, para burlar esse problema no packet tracer adicione a seguinte acl:
!R1
access-list 102 permit ip host 172.30.2.2 host 172.30.1.2
access-list 102 permit ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255

!R2
access-list 102 permit ip host 172.30.1.2 host 172.30.2.2
access-list 102 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255

Problema resolvido!

Arquivos Usados


Arquivo com problema
Arquivo Corrigido

terça-feira, 5 de março de 2013

Cisco abre o protocolo EIGRP

EIGRP (Enhanced Interior Gateway Routing Protocol) era um protocolo proprietário da Cisco que só existia em roteadores cisco, agora ele será liberado para que outros fabricantes também possam utiliza-lo.

Confira o video:

Cisco libera EIGRP (o vídeo está em inglês)

O que isso quer dizer?


A internet é composta pelas mais diversas rotas espalhadas pelo mundo, muitos dispositivos diferentes, muitos fabricantes diferentes. Existem protocolos de roteamento simples, que fazem o cálculo da melhor rota, visto que existem vários meios de chegar ao mesmo lugar, de diferentes maneiras, esse processo é chamado de métrica.

Cada protocolo de roteamento possui sua própria métrica, algumas mais simples e limitadas e outras mais complexas e eficientes. Os protocolos mais usados são os livres (IETF) como:

  • RIP - Métrica: caminho mais curto, com menos roteadores, até o destino

  • OSPF - Métrica: caminho mais rápido, com maior largura de banda, até o destino


Ambos funcionam perfeitamente porém o EIGRP, que até o começo do ano era proprietário da cisco, possui uma métrica mais complexa e interessante.

Protocolo EIGRP


O EIGRP usa o algoritmo DUAL para calcular sua melhor rota e criar sua tabela de topologia baseando-se em:

  • Largura de banda

  • Atraso

  • Carga

  • Confiabilidade

  • MTU


Além de outras particularidades como balanceamento de carga utilizando custo desigual, a maneira como o EIGRP escolhe a rota ou conhece a rede, etc.

O que vai mudar?


Muitas vezes é necessário redistribuir as rotas de um roteador para o outro, pois os fabricantes são diferentes e os protocolos de roteamento dinâmico também e com isso a fidelidade da melhor escolha acaba sendo prejudicada. Agora com essa liberação da Cisco qualquer equipamento será compatível com EIGRP (pelo menos após a implementação do mesmo em roteadores diferentes de Cisco).

Link para o projeto IETF: http://tools.ietf.org/html/draft-savage-eigrp-00

Se interessou pelo EIGRP?


Esse post aborda apenas a mudança feita pela cisco, caso você tenha interesse em conhecer mais sobre o EIGRP ou até mesmo implementa-lo segue abaixo alguns links que possam te ajudar:

segunda-feira, 4 de março de 2013

Solução VoIP Cisco - Voz Sobre IP

[caption id="attachment_69" align="alignnone" width="270"]Um dos mais usados hoje em dia Telefone IP - Um dos mais comuns[/caption]

Um aluno me ligou perguntando sobre como funciona uma solução VoIP Cisco de maneira beeeeeem simples, prometi a ele um email porém aproveitei a idéia para criar esse post, so there we go:

VoIP é a voz sobre IP, basicamente é um telefone que recebe um IP e consegue fazer ligações para ramais, porém em cima de uma rede digital e não analógica.

Podemos dividir uma solução VoIP em 2 partes:

  1. Parte puramente VoIP

  2. Parte que mescla VoIP com a rede analógica (não podemos nos isolar do resto do mundo não é?


A parte puramente VoIP é composta por dispositivos intermediários e dispositivos finais:

DI:
Irão ficar no meio da rede, levando o tráfego para lá e para cá, neles podem estar envolvidos:

  • Roteadores

  • Access Point

  • Switches

  • Aceleradores de Rede (Riverbed, WAAS)


Basicamente esses dispositivos irão se encarregar de levar as comunicações de um lado para o outro, são neles que criamos regras de QoS para priorizar o tráfego de voz (SIP, H.323, TCP 1720, etc) e em alguns casos video

DF:
Dispositivos que irão receber o tráfego:

  • Telefones IP

  • Computadores (com um programa chamado softphone com uma licença válida)

  • Celulares IP (sim existe)

  • Servidores VoIP (Cisco CallManager, Asterisk, etc)

  • Roteadores (eles também aceitam configurações de planos de discagem para linhas analógicas com wics FXO / FXS)


Esses dispositivos serão os responsáveis por gerenciar e iniciar uma comunicação através das configurações setadas.

Agora partindo para a parte Cisco:No Cisco CallManager (Server ou Express) você configura os ramais, usuários, planos de discagem, houting group entre outros

Os dispositivos devem se comunicar com o CallManager, se autenticar e receber seu ramal (dessa maneira tanto faz o telefone que você senta, seu ramal será sempre o mesmo).
Quando um telefone tenta ligar para algum lugar ele troca informações com o CallManager, incia a chamada e quando a conexão é estabelecida o CallManager sai de cena e a comunicação fica peer-2-peer, portanto ele apenas gerencia a conexão até que a mesma se estabeleça.

Existem muitos recursos que podem ser instalados em telefones IPs como listas de contato compartilhadas, planos de discagem, redução de custo entre muitas outras coisas, porém não irei escrever aqui para não fugir muito da idéia de deixar simples, finalizo por aqui, qualquer dúvida é só falar.

Básico sobre um Roteador Cisco

Um roteador cisco é como um computador:



  • Realiza o POST (Power-On-Self-Test)

  • Executa a BIOS (bootstrap)

  • Possuem um sistema operacional

  • Memória ram

  • Memória flash e nvram (seria os tipos HD)

  • Fonte de energia


Uma coisa curiosa do roteador é que você pode apagar o sistema operacional enquanto ele está sendo executado. Quando o roteador "inicializa" o SO ele irá copiá-lo para a memória ram e por isso é possível apaga-lo após a sua execução facilitando assim a atualização do mesmo!

Mas pra que serve um roteador cisco?


Nossa internet existe graças a existência de roteadores (não apenas de roteadores, mas eles são bem importantes) ao redor do mundo, dentro dos provedores de serviço de internet (ISP - Internet Service Provider) e, muitas vezes, em nossas casas!

Possuem a função realizar a comutação de pacotes e seleção de caminho.

[gallery columns="2" ids="50,49" orderby="rand"]

Pacotes?Endereços IP, chamamos de pacote devido ao Modelo OSISeleção de Caminho? Baseando-se na camada 3 (pacote - OSI) o roteador sabe para onde mandar a sua informação; Para acessar qualquer site na internet, vulgo WAN, você, sem saber, utiliza de pelo menos 2 roteadores pois são redes diferente da sua!

Não existe apenas um tipo de roteador, pois eles podem, além de selecionar o caminho e realizar a comutação de pacotes, ser focados a outras áreas como:

  • Segurança

  • VPN

  • Voz sobre IP (VoIP)

  • ETC


Todo esse conteúdo faz parte da área de TI que envolve redes, segurança, VoIP, provedor de serviço entre outras. Pode-se se dizer que este é o conteúdo básico para o desenvolvimento de um profissional na área de redes, porém é bom manter o olhos no mercado e observar as tendências.

Como se configura um roteador cisco?


Por padrão o roteador cisco vem zerado, sem configuração para rotear os pacotes, portando é necessária uma comunicação meio diferente para começar a configurá-lo, conecta-se um cabo console (rollover) no roteador e no computador (db-9) e assim uma conexão console é formada. Utilizando as especificações do manual do dispositivo, configura-se a conexão para (numa tela de um programa de terminal isso é fácil de se configurar):

  • 9600bits/s

  • 8 data bits

  • Sem paridade

  • 1 bit de parada

  • Sem controle de fluxo


Após configurar o roteador é possível administra-lo usando conexão telnet, ssh, http ou até mesmo usar o CSM (Cisco Security Manager) para um gerenciamento centralizado

Curioso sobre Roteadores Cisco? Que tal dar uma lida na nossa área de estudos?
Modelo OSI
Roteadores Cisco

sexta-feira, 1 de março de 2013

Recuperando a senha de ROOT Linux (Debian, Ubuntu, Kubuntu)

Recuperar a senha de root do linux é bem simples, porém poucas pessoas sabem do processo ou da sua simplicidade. Esse pequeno tutorial ajuda a recuperar a senha de root de Qualquer OS baseado em Debian usando GRUB:

Processo:



  1. Primeiramente reinicie a máquina (se for Ubuntu, fique pressionando a tecla SHIFT durante o boot para que seja exibido o menu do Grub).

  2. No menu acima, selecione a versão de kernel que você está usando e pressione a tecla “e”:

  3. No final da linha linux /boot/vmlinux-x.x.xx (…) $vt_handoff adicione o conteúdo abaixo:


rw init=/bin/bash

  1. Após isso tecle F10 e será aberto um terminal como o mostrado abaixo:

  2. Após isso, siga os seguintes passos:


mount -o remount,rw /
mount -a
mount


  1. Altere a senha da maneira que quiser (passwd ou alterando o arquivo shadow)

  2. Salve tudo e:


sync
umount -a
mount -o remount,ro /

Ctrl + Alt + Del para reiniciar e pronto!

Simples, rápido e direto!

Caso tenha interesse em mais tutoriais de linux:



Desejo um ótimo final de semana.